Archive for April, 2013

Mountain Lion System Requirements

To install Mountain Lion, you need one of these Macs:

  • iMac (Mid 2007 or newer)
  • MacBook (Late 2008 Aluminum, or Early 2009 or newer)
  • MacBook Pro (Mid/Late 2007 or newer)
  • MacBook Air (Late 2008 or newer)
  • Mac mini (Early 2009 or newer)
  • Mac Pro (Early 2008 or newer)
  • Xserve (Early 2009)

               Your Mac needs:

  • OS X v10.6.8 or OS X Lion already installed
  • 2 GB or more of memory (RAM)
  • 8 GB or more of available hard disk space

Leave a comment